The only printer in the computer science students' union is experiencing an extremely heavy workload. Sometimes
there are a hundred jobs in the printer queue and you may have to wait for hours to get a single page of output.
Because some jobs are more important than others, the Hacker General has invented and implemented a simple priority system for the print job queue. Now, each job is assigned a priority between 1 and 9 (with 9 being the highest priority,
and 1 being the lowest), and the printer operates as follows.
The first job J in queue is taken from the queue.
If there is some job in the queue with a higher priority than job J, thenmove J to the end of the queue without printing it.
Otherwise, print job J (and do not put it back in the queue).
In this way, all those importantmuffin recipes that the Hacker General is printing get printed very quickly. Of course, those annoying term papers that others are printing may have to wait for quite some time to get printed, but that's life.
Your problem with the new policy is that it has become quite tricky to determine when your print job will actually be completed. You decide to write a program to figure this out. The program will be given the current queue (as a list of priorities) as well as the position of your job in the queue, and must then calculate how long it will take until your job is printed, assuming that no additional jobs will be added to the queue. To simplifymatters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.
Input
One line with a positive integer: the number of test cases (at most 100). Then for each test case:
One line with two integers n and m, where n is the number of jobs in the queue (1 ≤ n ≤ 100) and m is the position of your job (0 ≤ m ≤ n −1). The first position in the queue is number 0, the second is number 1, and so on.
One linewith n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The first integer gives the priority of the first job, the second integer the priority of the second job, and so on.
Output
For each test case, print one line with a single integer; the number of minutes until your job is completely printed, assuming that no additional print jobs will arrive.
Sample Input
3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1
Sample Output
1
2
5
Solving Problem
Insert all values into the queue. Arrange the priority values forward first, then remove the value from the queue when the maximum value appears, and add 1 to the answer. If repeated, the break is executed when the value corresponding to location is reached and the repeat statement is terminated.
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
|
package algo;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;
class Main {
public static void main(String[] args) throws NumberFormatException, IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
int n=Integer.parseInt(br.readLine());
for(int i=0;i<n;i++) {
StringTokenizer st = new StringTokenizer(br.readLine());
int length=Integer.parseInt(st.nextToken());
int location=Integer.parseInt(st.nextToken());
int [] priorities = new int[length];
StringTokenizer st2 = new StringTokenizer(br.readLine());
for(int j=0;j<length;j++) {
priorities[j]=Integer.parseInt(st2.nextToken());
}
System.out.println(solution(priorities,location));
}
}
public static int solution(int[] priorities, int location) {
int answer = 0;
PriorityQueue<Integer> que = new PriorityQueue<Integer>(Collections.reverseOrder());
int cnt=0;
for(int e:priorities) {
que.add(e);
}
while(!que.isEmpty()) {
for(int i=0;i<priorities.length;i++) {
if(que.peek()==priorities[i]) {
que.poll();
answer++;
if(location==i) {
que.clear();
break;
}
}
}
}
return answer;
}
}
|
cs |
'Algorithms > Coding_Contest' 카테고리의 다른 글
[그래프 위상정렬] Topological Sort : Java (0) | 2021.07.20 |
---|---|
[Codeforce/round#611] Minutes Before the New Year [Java] (0) | 2019.12.29 |